2014年12月25日木曜日

2 繰り返し

①指定回数の繰り返し

「…」! n 繰り返す。


ブロック(「  」に囲まれた部分)を n 回繰り返すという文です。


【プログラム例2】
カメ太=タートル!作る。
「カメ太!100 歩く 90 右回り」!4 繰り返す。


プログラム例1と同じ動作をします。文がすっきりするのはもちろんですが、更に優れた点があります。
このパラメータ(数字の部分)を2ヶ所変更するだけで、他の多角形が簡単に書けることです(実際は画面からはみ出すので「100」の部分も変更が必要になることがありますが)
※今、何回目かはブロックのパラメータとして受け取ることができます。

「|i| …」! n 繰り返す。


iの両サイドの記号は、アルファベットのエルやアイではなく、縦棒です。キーボードでどうしても見つからない人は「たてぼう」と打って変換してみてください。


【プログラム例3】
「|i|ラベル!(i+”回”)作る。」! 10 繰り返す。


②条件を満たしている間繰り返す。
「…」! の間「…」実行。

【プログラム例4】
1   値=0。
2   「値<10」!の間
3        「ラベル!(値+”回”) 作る。値=値+1」
4   実行。



0 件のコメント:

コメントを投稿